« PDF万能ライブラリー:Quick PDF Libraryに関するブログを始めました | トップページ | Google ChromeとPDFのレイヤー機能(透かし機能)の制御 »

2012/12/26

ブラウザが古いバージョンのAdobe Readerを警告し出した。「このプラグインは安全ではありません。」


お名前.com デスクトップクラウド for Windowsアプリ

Adobe Readerの脆弱性がたくさん発見される中で、ブラウザ各社は古いバージョンのAdobe Readerを使い続けることの問題を認識し始めているようだ。

Google Chromeで、Chrome内蔵のPDFビューアを無効にして、Adobe Readerを有効にしている場合、Adobe Readerのバージョンが古いと(私が確認したところでは2012年12月現在、バージョン10.1.4及びバージョン11.0のみホワイトリスト)、PDFファイルを開くたびに下記のような警告が表示される。

Adobe Readerを実行するにはユーザーの許可が必要です。
Adobe Readerを実行するにはユーザーの許可が必要です。

このことはかなり前から気づいていたし、そもそもChrome内蔵のPDFビューアをわざわざ無効にしてAdobe Readerを使っているような上級ユーザーであれば、言われなくてもバージョン10の最新版か、バージョン11を使っているであろう。仮に古いバージョンを使っていても、アップグレードを促されればやり方をほとんど知っているだろうと思う。実際、アクセスログを解析したところ、9割がたの人たちは10.1.4もしくは11.0を使っているようだ。どちらかというと一般的なWEBユーザーが多いIEユーザーとは大違いだ。

が、Firefoxでも最近下記のような警告が私のテスト環境でも出現し出した。ただし、出現状況が一様ではなく、イマイチ分からない。

このプラグインは安全ではありません。更新してください。

このプラグインは安全ではありません。更新してください。更新を確認する。ここをクリックすると、Adobe Acrobatプラグインを有効にします。

Firefox 17.0.1だけの現象かと思うと、Firefox1 17.0.1でもこのような警告が表示されない端末もある。Adobe Readerのバージョン9を使っているのにだ。そうかと思えば、数時間前までは何の警告も出ていなかったのに、Windows Updateでもあたったかのように、起動したままのブラウザで再度同じPDFファイルを表示させた際にも、この警告が表示された端末もあった。

たまたまか分からないけれど、Firefoxでこの警告が出たのは、いずれもWindows XPであった。でも、Windows XP+Firefox 17.0.1+Adobe Reader X(10.1など10.1.4ではないもの)の場合でも警告が表示されない端末も多い。再現条件がよく分からない。

2013年1月17日午後18時21分ごろ追記
------------
Vista+Adobe Reader 7の端末でもこの警告を見るようになったので、XP限定というのは間違いのようだ。
-------------

関係ないかもしれないが、Flash Playerを最新版にアップデートした直後からだったような気もする。Flash Playerを最新版にアップデートしていない人に対して、Flash Playerをまずアップデートして、Adobe Readerをアップデートしてくださいというのは要求が多すぎるから、Firefoxが遠慮して、Flash Playerが最新版になっている場合のみ、古いバージョンのAdobe Readerを警告しだしているのか・・・。謎だ。

いずれにせよ、私のように仕事でどうしてもいろいろなバージョンのAdobe Readerでの確認が必要な場合を除いては、最新版にアップデートするようにされた方が無難だ。年末年始に時間がある時に、Adobe Readerが振るい方はアップデートしてみてはいかかでしょう?

|

« PDF万能ライブラリー:Quick PDF Libraryに関するブログを始めました | トップページ | Google ChromeとPDFのレイヤー機能(透かし機能)の制御 »

コメント

こんにちは。

当方が社内でサポートしているセールスフォース上のシステムでも、昨日(12/26)から複数のユーザにて同様の状態になりました。

システムの各レコードに添付されているPDFファイルを開こうとすると、まさにご記載の状態になります。
当方の環境では一般ユーザにadministrator権限を与えていないためか、プラグインがアップグレードできない状態です。

環境は全てXPです。Flash Playerのプラグインのアップグレードについては、上記の状態のためアップグレードはされていません。

何か更新情報がありましたら掲載いただけると幸甚です。

よろしくお願いします。

投稿: SalesForce利用者 | 2012/12/27 12:15

ブログ管理者です。

お察しのとおり、一般ユーザにadministrator権限を与えていないことが原因のように思われます。

いくつか対応方法が考えられると思います。以下の方法は、きっちりとした検証をしたわけではないです。思いつくまま書きます。

方法1.正攻法で行く。その端末にadministorator権限でログインできる人がログインして、アップデートを行う。もしくは一般ユーザーでログインしておいて、Adobe Readerのショートカットアイコン上で右クリックをして、「Administorator権限で起動」のようなメニューを選びパスワードを入力する。その上で、ヘルプメニューからアップデートを実行します。

方法2:Salesforceは使ったことがないので仕様がよく分かりませんが、ブラウザ内にPDFファイルが表示される仕様だということですか? であれば、Firefoxの設定で、ブラウザ内ではなく、PDFファイルをいったん保存して開く設定にできますので、Firefoxの設定を各端末で変えてください。

方法3:ユーザーにIEでアクセスするように促す。

方法4:結局は管理者権限が必要かもしれませんが、Adobe Reader以外のPDFビューア、たとえばFoxit ReaderやPDF XChangeなどをインストールする。

方法5:面倒だけれど、PDFの表示のたびに毎回、「ここをクリックするとAcrobatプラグインを有効にする」のメッセージをクリックする。

方法6: 入手方法はさておき、Firefoxのバージョン16以下を別フォルダーにインストールして、利用する。

方法7:Firefoxには内蔵のPDFビューアがあります。pdf.jsというものです。現在はデフォルトでは無効になっています。これをabout:configから有効にして、かつ、ツール→オプションからPDFのハンドラーをpdf.js(「Firefoxでプレビュー」)を選ぶと、うまくいくかもしれません。

投稿: ブログ管理者 | 2012/12/30 08:38

コメントを書く



(ウェブ上には掲載しません)


コメントは記事投稿者が公開するまで表示されません。



トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/67411/56398872

この記事へのトラックバック一覧です: ブラウザが古いバージョンのAdobe Readerを警告し出した。「このプラグインは安全ではありません。」:

« PDF万能ライブラリー:Quick PDF Libraryに関するブログを始めました | トップページ | Google ChromeとPDFのレイヤー機能(透かし機能)の制御 »